Forum Thread: Update from 4.0.4

My GS3 does not allow me to upgrade software, or I cant find the option.
My wifes SG3 (a year newer) does automatically.
Is there a manual way of doing this?

5 Responses

Cheers Herman, checked xda out as well and they had lots of options, Kies being the easiest.

Hey Neil. The manual way to check for updates is to go to Settings and scroll all the way down to the bottom where you will see "About Device." Tap this and at the very top there will be a Software Update option. Go there and check for updates. That should at least check to see if there are any updates available on your device.

Tried that first. the Software Update option is not available.
I searched around and read a bit on other sites and i have managed to upgrade to 4.1.2 using Kies.
thanks for replying tho

Hi. Two weeks ago my phone was stuck on the s3 logo. Tried to rwmove the battery. But when i turned it on again still stuck on the logo. Then i tried to charge it but again the battery figure appears but not charging but instead stuck in a loading mode. So i went to a cellphone repair shop. They said it needs to be reprogrammed. So i said ok. They have fixed it but my problem now is that the OS that they programmed is back to ICS. THEN i tried to update the software to 4.1.2 by using OTa and samsung kies but it said no available software update. So iwent back to the repair shop and thwy said that he tried update it but errors occur either on message or wifi connection. Can my s3 i9300 can be upgraded without those errors as the techniciqn have said. Please help.

Share Your Thoughts

  • Hot
  • Active